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Chapter 1 - Network Wiring Diagram

Connect a cMT2000/3000x HMI to a router by an Ethernet cable as the diagram shows below.

The default IP address of LAN 1 is DHCP. The default IP address of LAN 2 is the static IP 

192.168.100.1. The IP addresses of LAN 1 and LAN 2 must be configured to different subnets, 

except for cMT2000/3000x HMIs which have been activated with a CODESYS license.

cMT2000/3000x LAN ports: cMT2000/3000x HMIs are equipped with two independent 

Ethernet ports which isolate the device network from the company/factory network. LAN1 is a 

WAN (Wide Area Network) port which is allowed to connect to a public network or another 

network via a gateway. LAN2 is a LAN (Local Area Network) port.
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Chapter 2 - Setup

Tap the system toolbar button in the top left corner to open the setup menu.

System Properties

This menu shows general information about the cMT2000/3000x HMI and its Date & Time (RTC).

HMI Name - You can change the name of a cMT2000/3000x HMI to identify this HMI when 

retrieving historical data or loading a project from a PC. This saves time remembering the IP 

address of each cMT2000/3000x HMI.

Date, Time - You can adjust a cMT2000/3000x HMI's RTC manually.
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Note regarding the password requirement for some advanced settings: Changing some 

settings will require you to enter the password in advance. Generally, there are two different 

levels of password protection. Admin can be used to change all advanced settings. Select 

Admin and enter the admin password. By default, the password of Admin is 111111.

After login, the icon will become unlocked, and the text will become “Admin.”

Brightness - You can adjust the brightness of the screen. For some HMI models, there is a 

setting that allows you to adjust audio volume for the built-in speaker.

Sound - You can activate the built-in beeper of the HMI.
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Touch Sensitivity - If the HMI is equipped with a capacitive touchscreen, you can change the 

level of touch sensitivity if needed. By default, the level is set to High.

Language - Select a language for the system settings menu. The language selected on the 

EBPro project of the cMT2000/3000x HMI won't be affected by this language setting.
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Input Method - Select a language or multiple languages for the system keyboard input.

Show Start Button - You can hide the system toolbar button if needed.

Show Download Popup Window - If enabled, after inserting a USB disk (or SD card) to the USB 

host port (or SD card slot) of the cMT2000/3000x HMI, the Upload/Download dialog prompt 

window will pop up on the HMI screen.

Show Mouse Cursor - You can display a mouse cursor on the HMI screen.

Direction- You can change the screen display to portrait orientation or landscape orientation.
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System Metrics - displays CPU loading and information about RAM memory usage, flash 

reading/writing rate, ethernet usage, and eMMC health status.

Reset HMI to Default - This option is used to reset the cMT2000/3000x HMI to its factory 

default settings. Tap the Reset button to confirm this process.

OS Upgrade - This option is used to upgrade the OS version of the cMT2000/3000x HMI.
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Project

This menu shows you options regarding your EBPro project.

Clear History - This option is used to clear historical data, recipes, and recipe database stored in 

the internal memory of the cMT2000/3000x HMI.

Restart EB Project - Restarts the project of the cMT2000/3000x HMI and restores it to its initial 

state without cycling power. Tap the Restart button to confirm this process.
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Network

This menu shows you information and options regarding the ethernet ports.

You should configure the IP addresses of Ethernet 1 (LAN1) and Ethernet 2 (LAN2) when using 

the HMI. By default, the IP address of Ethernet 1 is DHCP, and the IP address of Ethernet 2 is 

192.168.100.1. The IP addresses of Ethernet 1 and Ethernet 2 must be on separate subnets, 

except for cMT2000/3000x HMIs with CODESYS activated.

Click on the “>” button. Enable Automatic (DHCP) or set the IP address manually when Manual 

(Static IP) is selected.



Page 12

cMT 2000/3000x Series User Manual

Network Bridge - This option will make the HMI behave like a two-port ethernet switch instead 

of the dual ethernet subnets by default.

When activating the Network Bridge, the prompt window will pop up. Click OK.
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Then you will notice that the Ethernet 2 is unconfigurable and marked as Bridge mode.

Note: Do NOT connect both ethernet ports to the same network when bridge mode is 

active or this will create a network loop and broadcast storm, breaking the network.
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Security

This menu is used to change the passwords for operating a project via cMT viewer, loading a 

project to the HMI, accessing FTP server, and so on. There are three different user levels of 

password protection, User, Update Project, and Admin. By default, the passwords of the three 

user levels are 111111.

User - This level can operate the cMT project via cMT viewer.

Update project - This level can load and retrieve the HMI project, as well as retrieve historical 

data, such as data sampling and event log data. In addition, it can operate the cMT project via 

cMT viewer.

Admin - This level has access to all system settings, load and retrieve the project, retrieve 

historical data, and operate the cMT project via cMT viewer. It is the highest security level.

History - For the FTP server access or USB upload. By default, the password is 111111. In 

addition, it can operate the cMT project via cMT viewer.

To prevent unauthorized users from accessing the HMI via cMT Viewer using the password 

“111111”, change the “Admin” password, the “Update project” password, the “History” 

password, and the "User" password.
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EasyAccess2.0

EasyAccess 2.0 is a tool that allows users to access and control a cMT2000/3000x HMI remotely 

from anywhere in the world. A few cMT2000/3000x HMIs are pre-licensed EasyAccess2.0.

For more information about EasyAccess2.0, refer to an EasyAccess2.0 user manual.
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CODESYS

This menu is used to activate the CODESYS runtime. To activate this feature on a 

cMT2000/3000x HMI, a CODESYS license is required from Maple Systems.

Activate CODESYS - Enter the codes shown on a CODESYS license. Click Activate to activate 

the CODESYS runtime.

Note: Once CODESYS is activated, there is no way to remove the CODESYS license from 

the cMT2000/3000x HMI.

Restore CODESYS License - The CODESYS functionality will be restored if it is enabled. Contact 

Maple Systems before using this.

VNC

The VNC server provides remote HMI monitoring and controlling via an ethernet connection.

Enable - Allows the VNC server to run on the HMI. Only one VNC client can get connected to 
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the VNC server.

Multi Connection - Allows connection with multiple VNC clients. Connecting the VNC server to 

too many VNC clients may slow down the communication speed and HMI performance.

Require Password- Specify a password. Logging into a VNC server will require the password.

FTP

The FTP server provides a way to remotely retrieve historical data from the HMI.

Enable - Allows the FTP server to run on the HMI.

FTP Port - Click the “>” button to change FTP port number.

FTP Client Can Modify USB/SD data - If enabled, historical data stored in USB drive/SD card 

can be modified using any FTP (File Transfer Protocol) clients.
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Printer

This menu allows you to build a connection between the HMI and your ethernet-based printer. 

For applicable printer types, refer to related documentation.

Install Printer - Click the “>” button to search for applicable printers on your network. Then 

select a printer by tapping the Install button.
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Then tap the Install button to confirm this process.

Now the driver of the printer has been installed on the HMI.
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Theme

You can choose light or dark theme for your System Settings UI.
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Chapter 3 - Web Interface

A cMT2000/3000x HMI's setting can also be accessed via a web browser. Before configuration, 

connect cMT2000/3000x HMI (LAN1) to a router via an Ethernet cable. Open a web browser 

(Edge, Chrome, or Firefox) and enter the IP address of the cMT2000/3000x HMI. For example, 

enter 192.168.1.15. Select an identity and enter its password.

The tabs of the web interface are displayed as shown. They are System, Network, Project, 

Data, Features, Weincloud, and Administration.



Page 22

cMT 2000/3000x Series User Manual

Feature Introduction

System > Info

Now within Date/Time - Synchronizes the HMI RTC with the PC RTC.

Project > Project Management

Restart Project - Restarts cMT2000/3000x HMI and restores it to its initial state.

Update Project- Loads a project and recipes from the PC to cMT2000/3000x HMI.

Backup Project- Uploads a project from cMT2000/3000x HMI to the PC.

USB/SD Update- Loads a project via a USB drive/SD card plugged into the slots of 

cMT2000/3000x HMI. Select the *.cxob file and click Update.
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Project > Email

This page provides setup of the SMTP server and email contact lists. For more information, refer 

to section 5.11 e-Mail in the EBPro user manual.
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Project > Recipe

Update - Select a button to transfer recipe files from the PC to the cMT2000/3000x HMI.

Backup - Select a button to transfer recipe files from the cMT2000/3000x HMI to the PC.

Clear - It is used to clear recipe and database information stored in cMT2000/3000x HMI.

Data > Data Log & Trend Display

This page displays data log information via a data spreadsheet or a trend chart. Data within each 

spreadsheet can be backed up individually by clicking Export to Spreadsheet or Backup 

database.

Export to Spreadsheet - This function generates a CSV file.

Backup database - This function generates a compressed file of the .db files.
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Data > Event Log

This page displays a data table in which operators can easily see important event information 

recorded on the HMI.
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Data > Operation Log

This page allows you to back up operation log information recorded on the HMI.

Features > Webview Setting

Webview offers direct control over HMI screens using a web browser.

Set as homepage – If enabled, Webview will be the home page of the web interface.

Change password - Set a password to prevent unauthorized operators from accessing 

Webview.
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Webview - Go to the Webview page to control the HMI screen remotely.

If a password is set up for Webview, operators will have to enter the correct password.
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Features > CODESYS

Status - If activated, this tab shows CODESYS network information and status information.

Project update (If activated) - Loads CODESYS PLC project from the PC to cMT2000/3000x HMI. 

Navigate to the folder containing *.app file and *.crc file and choose them.

CODESYS update (If activated) - Upgrade CODESYS firmware from the PC to cMT2000/3000x 

HMI. Navigate to the folder containing *.bin file and choose it.
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Chapter 4 - How to Use WebView

Webview is used to monitor and control a cMT2000/3000x HMI on a web browser. It supports 

the following web browsers on a Windows PC, Chrome, FireFox, and Edge. Up to 4 users can 

access Webview simultaneously.

To use this feature, Webview must be enabled on the Webview Setting. You can set up 

password protection by clicking the Change password button. If password protection is not 

necessary for your application, check the password free button to disable password protection.

If Set as homepage is enabled on the Webview Setting tab, Webview will be the home page of 

the web interface.

How to login to Webview

1. Open a web browser and enter HMI’s IP address. 

2. Enter the correct password.
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3. The HMI screen will be displayed on the web browser. Use the "square" located in 

the bottom right corner to scroll around the screen when zoom level exceeds 

100%.

The toolbar located in the top left corner contains several menus.

The first group allows you to enable or disable the zoom function. When you select the “100” 

icon, you can change the zoom level of the screen.
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The second group allows you to move the “square” to the preferred location. This group of tools 

will be accessible when you select the “100” icon.

The third group allows you to navigate the system dashboard by clicking the “Gear” button.

Clicking the "Exit" button will log out Webview.

Why won't Webview open?

1. Webview is not enabled on Webview Setting.

2. The web browser you're using is not supported by Webview.

3. There are already 4 users accessing Webview simultaneously.
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Chapter 5 - How to Load a Project via USB 

Drive/SD Card (USB Drive >HMI)

1. Use Build Download Files function to build *.cxob file into a USB drive or SD 

card.

2. Plug the USB drive/SD card into to the corresponding slot of the cMT2000/3000x 

HMI. When a pop-up window is displayed prompting you to download or upload 

to your device, click on Download.

3. Enter the password. The password requires the level of Update Project or 

Admin. Then you can select which files you want to load into the HMI.
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4. Navigate to the folder containing *.cxob file and select it.

5. Click on OK to start. Then wait for a few minutes.
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Chapter 6 - How to Retrieve Historical Data via 

USB Drive/SD Card (HMI-> USB Drive)

1. Plug a USB drive or SD card to the corresponding slot of the cMT2000/3000x 

HMI. A pop-up window will display prompting you to download or upload to 

your device, and then click on Upload.

2. Enter the password. The password requires the level of History, Update Project 

or Admin. Then you can select which files you want to retrieve.

3. Specify a folder path for storing historical data.
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4. Click on OK to start. Then wait for a few minutes.
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Chapter 7 - How to Delete Historical Data

Go to the Project menu and enter the password to access this menu. Then select which historical 

data you want to delete.

Click on Clear and wait for a few minutes. The prompt window will state that the HMI has 

cleared historical data.
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Chapter 8 - OS Upgrade

1. Copy the new OS image to a USB drive. The USB drive must be formatted to 

FAT32 in advance. The OS image is the form of a *.bin file.

2. Plug the USB drive into the USB host port of the cMT2000/3000x HMI. If a 

window pops up and prompts you to download or upload, click close to dismiss 

it.

3. Go to the System Properties menu and find OS Upgrade. Enter the password to 

access this option.

4. Click on Choose File and navigate to the folder containing the OS image.

5. Click Upgrade in the top right corner.
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6. OS upgrade will begin, which may take minutes. Do not unplug the power cord 

during the OS upgrade. It may result in all data being lost. The progress bar 

indicates the progress of the OS upgrade. The HMI will reboot automatically 

when the OS upgrade is completed.
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Chapter 9 - cMT-Viewer

cMT-Viewer is a free client application, which can remotely access the screen of the 

cMT2000/3000x HMI located on the LAN (Local Area Network) via Wi-Fi connectivity or Ethernet 

cable connection. To use cMT-Viewer you need to download and install the cMT-Viewer App on 

a mobile device or PC. When the cMT-Viewer App runs on a device and connects to the 

cMT2000/3000x HMI, only data is exchanged between the device and the cMT2000/3000x HMI. 

Three client devices can remotely view and control the project of a cMT2000/3000x HMI 

simultaneously by default.

Supported OS Where to download Compatibility

Android phones or tablets Google Play store V4.1 or greater

iOS devices App Store V6 or greater

Windows PC Maple Systems’ official website

(Stand-alone App. or EBPro)

Windows 7 or Windows 10

Note: cMT-Viewer is installed with the EBPro package on a PC. To find it, launch the Utility 

Manager > Select cMT Series model > Maintenance tab > cMT-Viewer.
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Typical Application Diagram
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cMT-Viewer App Interface

Some operation options of the cMT-Viewer App opened on different operating systems may 

vary. This document discusses how to operate the cMT-Viewer App running on a PC. First, 

launch cMT-Viewer App.

Note: In this demonstration, version 2.6.38 of cMT-Viewer is used. The edit, Auto Play, 

and Page Indicator icons are only present when “Monitor Mode” functionality is enabled 

in the Settings page.
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Connect Menu - Click the Connect button and search for cMT2000/3000x HMIs in the Search 

tab. The available cMT2000/3000x HMIs will be shown as below when they exist on your local 

network. Tap an Add icon on the desired cMT2000/3000x HMI, and it will bring up a window 

requiring a password.

After that, the corresponding project will be loaded. If you want to go back to Connect menu, 

click on the Start (Home) button at the upper left corner.
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Add a second project to the cMT-viewer App to switch and view different projects. The small 

pictures of the images shown below are cMT2000/3000x projects before leaving the projects.

On the History tab, you can connect the recently 

accessed projects. If the cMT2000/3000x HMIs are 

configured to DHCP, the history records may not be able 

anymore since the IP addresses are dynamic. Click 

“clear” button to delete history records if needed. The 

“gear” buttons nearby each cMT2000/3000x HMI will 

open its web interface, allowing you to change the 

settings of the cMT2000/3000x HMI.
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Settings Menu

Information tab

Displays the current version of the cMT-Viewer application.

General tab

Provides general settings.

Change password - Allows users to change the password of “more settings” at the bottom left 

corner.

Display datetime bar - Determines if the time bar will be displayed at the top of cMT-Viewer 

application.

Adjust CMT Viewer to windows size - Adjusts cMT-Viewer to fit the window when users 

maximize the window of cMT Viewer App.

Portrait mode- Allows you to switch cMT Viewer to Portrait mode.



Page 45

cMT 2000/3000x Series User Manual

Language tab

Select a language for cMT-Viewer menus. The language selected on the project of the 

cMT2000/3000x HMI won't be changed by this setting.
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To enable Monitor Mode and use Password Protection functionalities, click on “more settings" 

icon and log in with the password set on "Change password." The default password is 111111.

There are more options available on the General tab and the Password Protection tab.

Monitor mode - Allows you to display multiple projects on cMT-Viewer and show important 

real-time data for the projects of each cMT2000/3000x HMIs.

Show Start button - If disabled, the “Home” icon on the project will be hidden.

Password Protection - Accessing the protected actions will require a password if actions are 

selected below. Specify a password on Change password of this page.
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o Open Project: The action to connect to cMT2000/3000x HMI and load its 

project.

o Close Project: The action to close projects on cMT-Viewer.

o Server Settings: The action to go to web interface of cMT2000/3000x HMIs.

o Clear History: The action to clear recently accessed projects on the History 

tab of the Connect menu.

When selecting actions, the Password Protect icon will be present.
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In Password Protection mode, protected actions are locked. To access them, click on the 

Password Protect icon and enter the corresponding password.

The protected actions are accessible to users with knowledge of assigned password. There is a 

countdown timer displayed as shown below. When the time runs out, the Password Protection 

mode will be activated.
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Chapter 10 - Monitor Mode

The small images of the cMT2000/3000x project as shown below will be updated automatically, 

so users will see the latest data without entering each cMT2000/3000x project.

Click on the Auto Play button. cMT-Viewer will automatically go to the next page.

To pause Auto Play mode, click the Pause button highlighted in red.

To leave Auto Play mode, click the Stop button highlighted in orange.
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When clicking on the Device Information button, the names of each cMT2000/3000x HMI, as 

well as their IP address, will be displayed as shown below. Tap the “Gear" (Setup) buttons to go 

to the web interface of each cMT2000/3000x HMI.

Click the Edit button to configure the page layout.
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Edit Menu

Page - Click the Add button to create a new page or delete the current page with the Delete 

button. Up to 9 pages can be created in each instance of cMT-Viewer.

Move the current page - Switch to the first page, the previous page, the next page, or the last 

page.

Layout - Set up the maximum number of projects in each page. It provides 3x3(9) format and 

5x4(20) format.

AutoPlay - Set up the time interval for Auto Play mode to go to the next page after the given 

time interval.
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Note: To show real-time data for the project of a cMT2000/3000x HMI like below, you must 

enable Monitor Mode in EBPro and create a screen for visualization. Here are steps to configure.

1. Launch EBPro software v6.01.01 or greater.

2. Create a project of cMT2000/3000x HMI.

3. Go to the Home tab > System Parameters.

4. In the System Parameters, click on General tab.

5. Enable Monitor Mode checkbox. This option is turned off by default.

6. Close System Parameters settings. Open the window no.3, titled Monitor Mode.
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7. Place Text object, Bit Lamp object, Word Lamp object, Numeric Display object, 

ASCII Display object, Bar Graph object or Alarm Display object to show up-to-

date data on this screen, so you can see the data shown and updated on the 

cMT-Viewer App while in monitor mode.

8. Download this project to a cMT2000/3000x HMI.
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Chapter 11 - cMT-Viewer Limitations

Feature Limitation

Some features do not work on a cMT Viewer client (PC, iOS, Android, cMT-iV5), even if they 

work on the local cMT HMI. Take this into consideration when programming projects.

Features (Objects) that do not work remotely on the cMT Viewer application:

• File Browser

• Media Player

• Video In: USB Camera

• Video In: IP Camera

• Video In: Video Input (analog)

• Picture View

• PDF Reader

• VNC Viewer

• Select features of Function Key: Screen hardcopy, Import user data/USB Security Key

• Selected features of PLC Control

o Screen hardcopy: Files are saved in the external drive on HMI

o Backlight: Backlight control of HMI screen

• Selected features of Operation Log

o Operation Log printing: Logs are saved in the external drive on HMI

The above objects won't be displayed on a cMT Viewer App but can be accessed via a VNC 

client or Webview.

Maximum Connect Count

Three cMT-Viewer clients are allowed to remotely view and control the project of a 

cMT2000/3000x HMI simultaneously by default. When the fourth cMT-Viewer client connects to 

the cMT2000/3000x HMI, the message below will pop up and reject the connection.
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The maximum capacity of cMT-Viewer clients can be adjusted in EBPro software:

1. Launch EBPro v6.01.01 or greater.

2. Go to the Home tab > System Parameters.

3. Click on the Remote tab.

4. Within cMT-Viewer, set up the number of cMT-Viewer max connections. Up to 10 cMT-

Viewer clients are allowed to connect to one cMT2000/3000x HMI.

Warning: Allowing a number of cMT-Viewer connections up to 4 or over will affect HMI 

performance. Take this into consideration when programming projects.
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Chapter 12 - cMT2000/3000x HMI Gestures 

Operation

Tap: This is the most common gesture. Briefly touch the HMI screen with your fingertip.

Drag: Move fingertip over HMI screen without losing contact.

Press: Touch HMI screen for extended period.

Pinch: Touch HMI screen with two fingers and bring them closer together.

Spread: Touch HMI screen with two fingers and move them apart.

Gestures may vary when operating projects on different touch screens.

On resistive touch screens:

Gestures Supported Objects (Features)

Tap All "Input" objects

Drag (Scroll horizontally, 

scroll up, and scroll 

down on the object to 

view more data)

Data log: Trend Display, History Data Display<br>Event log: 

Event Display, Event Bar Chart(Gantt)<br>Operation log: 

Operation Log View<br>Recipe: Recipe View<br>SQL: SQL 

Query Result Viewer<br>Others: Option-List, Data Block Display

Press This gesture can be configured on the property of the object in 

HMI program if needed.
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On capacitive touch screens:

Gestures Supported Objects (Features)

Tap All "Input" objects1

Drag (Scroll horizontally, 

scroll up, and scroll 

down on the object to 

view more data)

Data log: Trend Display, History Data Display<br>Event log: 

Event Display, Event Bar Chart(Gantt)<br>Operation log: 

Operation Log View<br>Recipe: Recipe View<br>SQL: SQL 

Query Result Viewer<br>Others: Option-List, Data Block Display

Press This gesture can be configured on the property of the object in 

HMI program if needed.

Pinch Data log: Trend Display

Spread Data log: Trend Display

1Input objects refer to objects that allow operators to open a window or pop-up window, press a button to turn a bit ON/OFF, or 

enter a value to a word register.

Note: For more information about Press, refer to section 10.5, Object Security Settings, in 

the EBPro user manual and see “Min. press time (Sec)."
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