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Chapter 1 - Network Wiring Diagram

Connect a cMT-SVRX to a router by an Ethernet cable as the diagram shows below.

The default IP address of LAN 1 is DHCP. The default IP address of LAN 2 is static IP 

192.168.100.1. The IP addresses of LAN 1 and LAN 2 must be configured to different subnets, 

except for the cMT-SVRX which have been activated with a CODESYS license.

cMT-SVRX LAN Ports
The cMT-SVRX is equipped with two independent Ethernet ports which isolate the device 

network from the company/factory network. LAN1 is a WAN (Wide Area Network) port which is 

allowed to connect to a public network or another network via a gateway. LAN2 is a LAN (Local 

Area Network) port.
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Chapter 2 - Web Interface

A cMT-SVRX's setting can also be accessed via a web browser. Before configuration, connect 

cMT-SVRX(LAN1) to a router via an Ethernet cable. Open a web browser (Edge, Chrome, or 

Firefox) and enter the IP address of the cMT-SVRX. For example, enter 192.168.1.15.

Select an identity and enter its password.

The tabs of the web interface are displayed as shown. They are System, Network, Project, Data, 

Features, Weincloud, and Administration.
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Feature Introduction

System > Info

HMI Name - Change the name of the cMT-SVRX to identify this HMI when retrieving historical 

data or loading a project on a PC. This saves time remembering the IP address of each cMT-

SVRX.

Identification light - If clicking this button, the LED on the cMT-SVRX will blink.

Now within Date/Time - Synchronizes the HMI RTC with the PC RTC.

Network > Ethernet

Set the IP addresses of LAN 1 port and LAN 2 port. Choose Automatic or Static for each. If 

Static is chosen, enter IP address, sub mask, gateway IP, and DNS. The IP addresses of LAN 1 

and LAN 2 must be on separate subnets.



Page 7

cMT SVRX Series User Manual

Project > Project Management

Restart Project - Restarts cMT-SVRX and restores it to its initial state.

Update Project - Loads a project and recipes from the PC to cMT-SVRX.

Backup Project - Uploads a project from cMT-SVRX to the PC.

USB/SD Update - Loads a project via a USB drive plugged into the USB slot of cMT-SVRX. 

Select the *.cxob file and click Update.
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Project > Email

This page provides the setup of the SMTP server and email contact lists. For more information, 

refer to section 5.11 e-Mail in the EBPro user manual.

Project > Enhanced Security

(Objects authorized to operators in HMI project)

This page provides user passwords and security classes to prevent unauthorized operators from 

accessing objects that have the potential to cause damage or injury within your cMT-SVRX HMI 

project. For more information, refer to section 5.6.2 Enhanced Security Mode in the EBPro user 

manual.
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Project > Recipe

Update - Select a button to transfer recipe files from the PC to the cMT-SVRX.

Backup - Select a button to transfer recipe files from the cMT-SVRX to the PC.

Clear - It is used to clear recipe and database information stored in the cMT-SVRX.

Data > Data Log & Trend Display

This page displays data log information via a data spreadsheet or a trend chart. Data within each 

spreadsheet can be backed up individually by clicking Export to Spreadsheet or Backup 

database.

Export to Spreadsheet - This function generates a CSV file.

Backup database - This function generates a compressed file of the .db files.
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Data > Event Log

This page displays a data table in which operators can easily see important event information 

recorded on the HMI.
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Data > Operation Log

This page allows you to back up operation log information recorded on the HMI.

Features > Webview Setting

Webview offers direct control over the HMI screen using a web browser.

Set as homepage - If enabled, Webview will be the home page of the web interface.

Change password - Set up a password to prevent unauthorized operators from accessing 

Webview.

Webview - Go to the Webview page to control the HMI screen remotely.
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If a password is configured for Webview, operators will have to enter the correct password.

Features > CODESYS

Status - If activated, this tab shows CODESYS network information and status information.
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Project update (If activated) - Loads CODESYS PLC project from the PC to the cMT-SVRX. 

Navigate to the folder containing *.app file and *.crc file and choose them.

CODESYS update (If activated) - Upgrade CODESYS firmware from the PC to the cMT-SVRX. 

Navigate to the folder containing *.bin file and choose it.
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Features > FTP

FTP Client can modify USB/SD data - If enabled, historical data stored in USB drive/SD card 

can be modified via FTP (File Transfer Protocol).

FTP port - If needed, you can change the port number for the connection to the FTP server 

(HMI).
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Weincloud > EasyAccess2.0

EasyAccess 2.0 is a tool that allows users to access and control a cMT-SVRX remotely from 

anywhere in the world. cMT-SVRX-820 is NOT a pre-licensed model, so purchasing an activation 

card is necessary. cMT-SVRX-822 is a pre-licensed model. For more information, refer to the 

EasyAccess2.0 user manual or Weincloud help website https://support.ihmi.net/. You can also 

contact Maple Systems sales team for support at https://maplesystems.com/contact-sales/ .

Administration > System Password

There are three different levels of password protection, User, Update Project, and System 

Setting. This page is used to change the passwords for operating a project via cMT viewer, 

loading a project to the HMI, accessing FTP server and so on. The default passwords of the three 

levels are 111111.

User - This level can operate cMT projects via cMT viewer.

Update project - This level can load and retrieve the HMI project and retrieve historical data, 

like data sampling and event log data. In addition, it can operate cMT projects via cMT viewer.

System Setting - This level has access to all system settings, load and retrieve the project, 

retrieve historical data, and operate cMT projects via cMT viewer. It is the highest security level.

History - FTP server access. The default password is 111111.

https://www.google.com/url?sa=E&q=https%3A%2F%2Fsupport.ihmi.net%2F
https://maplesystems.com/contact-sales/
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Chapter 3 - How to Use WebView

Webview is used to monitor and control a cMT-SVRX on a web browser. It supports the 

following web browsers on a Windows PC, Chrome, FireFox, and Edge. Up to four users can 

access Webview simultaneously.

To use this feature, Webview must be enabled on the Webview Setting. You can set up 

password protection by clicking the Change password button. If password protection is not 

necessary for your application, check the password free button to disable password protection.

If Set as homepage is enabled on the Webview Setting tab, Webview will be the home page of 

the web interface.

How to login to Webview

1. Open a web browser and enter HMI’s IP address.

2. Enter the correct password.
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3. The HMI screen will be displayed on the web browser. Use the “square” located in the 

bottom right corner to scroll around the screen when zoom level exceeds 100%.

The toolbar located in the top left corner contains several menus.
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The first group allows you to enable or disable the zoom function. When you select the “100” 

icon, you can change the zoom level of the screen.

The second group allows you to move the “square” to the preferred location. This group of tools 

will be accessible when you select the “100” icon.

The third group allows you to navigate the system dashboard by clicking the “Gear” button.

Clicking the "Exit" button will log out Webview.

Why won't Webview open?

• Webview is not enabled on Webview Setting.

• The web browser you're using is not supported by Webview.

• There are already four users accessing Webview simultaneously.
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Chapter 4 - cMT-Viewer

cMT-Viewer is a free client application, which can remotely access the screen of the cMT-SVRX 

located on the LAN (Local Area Network) via Wi-Fi connectivity or Ethernet cable connection. To 

use cMT-Viewer you need to download and install the cMT-Viewer App on a mobile devices or 

PC. When the cMT-Viewer App runs on a device and connects to the cMT-SVRX, only data is 

exchanged between the device and the cMT-SVRX. Three client devices can remotely view and 

control the project of a cMT-SVRX simultaneously by default.

Supported OS Where to download Compatibility

Android phones or 

tablets

Google Play store V4.1 or greater

iOS devices App Store V6 or greater

Windows PC Maple Systems official website (Stand-alone 

App. or EBPro)

Windows 7 or 

Windows 10

Note: cMT-Viewer is installed with the EBPro package on a PC. To find it, launch the Utility 

Manager > Select cMT Series model > Maintenance tab > cMT-Viewer.
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Typical Application Diagram

cMT-Viewer App Interface

Some operation options of the cMT-Viewer App opened on different operating systems may 

vary. This document discusses how to operate the cMT-Viewer App running on a PC. First, 

launch cMT-Viewer App.
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Note: In this demonstration, version 2.6.38 of cMT-Viewer is used. Edit, Auto Play, and 

Page Indicator icons are only present when “Monitor Mode” functionality is enabled in the 

Settings page.

Connect Menu - Click the Connect button and search for cMT-SVRXs in the Search tab. The 

available cMT-SVRXs will be shown as below when they exist on your local network. Tap an Add 

icon on the desired cMT-SVRX, and it will bring up a window requiring a password.
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After that, the corresponding project will be loaded. If you want to go back to Connect menu, 

click on the Start (Home) button at the upper left corner.

Add a second project to the cMT-viewer App to switch and view different projects. The small 

pictures of the images as shown below are images of the cMT-SVRX projects before leaving the 

projects.
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On History tab, you can connect the recently accessed 

projects. If the cMT-SVRXs are configured to DHCP, the 

history records may not be able anymore since the IP 

addresses are dynamic. Click "clear" button to delete 

history records if needed. The "gear" buttons nearby each 

cMT-SVRX will open its web interface, allowing you to 

change the settings of the cMT-SVRX.
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Settings Menu

Information tab

Displays the current version of the cMT-Viewer application.

General tab

Change password - Allows users to change the password of “more settings” at the bottom left 

corner.

Display datetime bar - Determines if the time bar will be displayed at the top of cMT-Viewer 

application.

Adjust cMT Viewer to windows size - Adjusts cMT-Viewer to fit the window when users 

maximize the window of cMT Viewer App.

Portrait mode - Allows you to switch cMT Viewer to Portrait mode.



Page 25

cMT SVRX Series User Manual

Language tab

Select a language for cMT-Viewer menus. The language selected on the project of the cMT-

SVRX won't be changed by this setting.
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To enable Monitor Mode and use Password Protection functionalities, click on “more settings" 

icon and log in with the password set on "Change password." The default password is 111111.

There are more options available on the General tab and the Password Protection tab.

Monitor mode - Allows you to display multiple projects on cMT-Viewer and show important 

real-time data for the projects of each cMT-SVRXs.

Show Start button - If disabled, the “Home” icon on the project will be hidden.

Password Protection - Accessing the protected actions will require a password if actions are 

selected below. Specify a password on Change password of this page.

• Open Project: The action to connect to cMT-SVRX and load its project.
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• Close Project: The action to close projects on cMT-Viewer.

• Server Settings: The action to go to web interface of cMT-SVRXs.

• Clear History: The action to clear recently accessed projects on the History tab of 

the Connect menu.

When selecting actions, the Password Protect icon will be present.

In Password Protection mode, protected actions are locked. To access them, click on the 

Password Protect icon and enter the corresponding password.
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Protected actions are accessible to users with knowledge of assigned password. There is a 

countdown timer displayed as shown below. When the time runs out, the Password Protection 

mode will be activated.
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Chapter 5 - Monitor Mode

The small images of the cMT-SVRX project as shown below will be updated automatically, so 

users will see the latest data without entering each cMT-SVRX project.

Click on the Auto Play button. cMT-Viewer will automatically go to the next page.

To pause Auto Play mode, click the Pause button highlighted in red.

To leave Auto Play mode, click the Stop button highlighted in orange.
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When clicking on the Device Information button, the names of each cMT-SVRX, as well as their 

IP address, will be displayed as shown below. Tap the “Gear” (Setup) buttons to go to the web 

interface of each cMT-SVRX.

Click the Edit button to configure the page layout.
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Edit Menu

Page - Click the Add button to create a new page or delete the current page with the Delete 

button. Up to 9 pages can be created in each instance of cMT-Viewer.

Move the current page - Switch to the first page, the previous page, the next page, or the last 

page.

Layout - Set up the maximum number of projects in each page. It provides 3x3(9) format and 

5x4(20) format.

AutoPlay - Set up the time interval for Auto Play mode to go to the next page after the given 

time interval.
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Note: To show real-time data for the project of a cMT-SVRX like below, you must enable 

Monitor Mode in EBPro and create a screen for visualization. Here are steps to configure.

1. Launch EBPro software v6.01.01 or greater.

2. Create a project of cMT-SVRX.

3. Go to the Home tab > System Parameters.

4. In the System Parameters, click on General tab.
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5. Enable Monitor Mode checkbox. This option is turned off by default.

6. Close System Parameters settings. Open window no.3, titled Monitor Mode.

7. Place Text object, Bit Lamp object, Word Lamp object, Numeric Display object, ASCII 

Display object, Bar Graph object or Alarm Display object to show up-to-date data on this 

screen, so you can see the data shown and updated on the cMT-Viewer App while in 

monitor mode.
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8. Download this project to a cMT-SVRX.
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Chapter 6 - cMT-Viewer Limitations

Feature Limitation

Some features do not work on a cMT Viewer client (PC, iOS, Android, cMT-iV5), even if they 

work on the local cMT HMI. Take this into consideration when programming projects.

Features (Objects) that do not work remotely on cMT Viewer App:

• File Browser

• Media Player

• Video In: USB Camera

• Video In: IP Camera

• Video In: Video Input (analog)

• Picture View

• PDF Reader

• VNC Viewer

• Selected features of Function Key: Screen hardcopy, Import user data/USB Security Key

• Selected features of PLC Control

o Screen hardcopy: Files are saved in the external drive on HMI

o Backlight: Backlight control of HMI screen

• Selected features of Operation Log

o Operation Log printing: Logs are saved in the external drive on HMI

Above objects won't be displayed on a cMT Viewer App but can be accessed via a VNC client.

Maximum Connect Count

Three cMT-Viewer clients are allowed to remotely view and control the project of a cMT-SVRX 

simultaneously. When the fourth cMT-Viewer client connects to the cMT-SVRX, the warning 

message as shown below will pop up and reject the connection.
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The maximum capacity can be adjusted in EBPro software. Here are the steps.

1. Launch EBPro v6.01.01 or greater.

2. Go to Home tab > System Parameters.

3. Click on Remote tab.

4. Within cMT-Viewer, set up a number of cMT-Viewer max connections. Up to 10 cMT-

Viewer clients are allowed to connect to one cMT-SVRX.

Warning: Allowing several cMT-Viewer connections up to 4 or over will affect HMI 

performance. Take this into consideration when programming projects.
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Chapter 7 - cMT-SVRX Gestures Operation

Tap: This is the most common gesture. Briefly touch HMI screen with fingertip.

Drag: Move fingertip over HMI screen without losing contact.

Press: Touch HMI screen for extended period.

Pinch: Touch HMI screen with two fingers and bring them closer together.

Spread: Touch HMI screen with two fingers and move them apart.

On cMT Viewer APP or capacitive touch screen

Gestures Supported Objects (Features)

Tap All "Input" objects1

Drag Data log: Trend Display, History Data Display<br>Event log: Event Display, Event 

Bar Chart(Gantt)<br>Operation log: Operation Log View<br>Recipe: Recipe 

View<br>SQL: SQL Query Result Viewer<br>Others: Option-List, Data Block 

Display

Press This gesture can be configured on the property of the object in HMI program if 

needed.

Pinch Data log: Trend Display

Spread Data log: Trend Display

1Input objects refers to objects that allow operators to open a window as well as pop-up window, press a button to turn bit ON/OFF, 

or enter a value to a word register.
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Note: cMT-SVRX doesn't support page switching by drag and flick gestures. For more 

information about Press, refer to section 10.5 Object Security Settings in the EBPro user 

manual and see “Min. press time (Sec).”
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Chapter 8 - OS Upgrade

This section shows you how to update the OS image of a cMT-SVRX.

1. Copy the MTfirmware.bin file to root folder of a micro SD card.

2. Flip DIP Switch 2 of the cMT-SVRX to ON position.

3. To monitor the update progress, run HyperTerminal software on your PC and set the 

parameters to 115200, 8, N, 1. Connect your computer with the cMT-SVRX via COM1 RS-

232 port.

4. Insert the micro SD card to cMT-SVRX and reboot to update the OS image. The update 

succeeds when HyperTerminal displays “Starting Kernel" about two minutes after reboot.

5. Power off the cMT-SVRX and then flip DIP Switch 2 of the cMT-SVRX back to OFF 

position.
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