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cMT X Series Easyweb 2.0

Chapter 1 System Settings

1.1 Overview

Easyweb 2.0 is a web interface that allows users to configure parameters of cMT X Series HMI.
Additionally, with its WebView feature, users can monitor HMls through a web browser. This user

manual explains the cMT X Series HMI features that can be configured using Easyweb 2.0.

1.2 Ways to Log In Easyweb 2.0

Connect an HMI via an Ethernet cable, and log in system settings in one of the following ways.

Via internet browser

Open internet browser (Windows Edge, Chrome, or Firefox), and enter HMI’s IP address (e.g.:
192.168.2.121). The web page below opens. If WebView interface is shown after entering the IP
address, please enter https://HMI_IP/admin to open Easyweb 2.0 system login page.

W Easyweb

Welcome back

B S & cMT-1E7C_FAE_cMT3072XH .

Set on cMT Viewer devices

[ o |

Launch cMT Viewer App, tap Search, select the HMl and tap * icon to configure.
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-
JZ, eMT Viewer

D17-03-29 104806
Connect

Search

Q Name/ 1P

1 CMT-4CE6
" 192.168.2.121

, Default HMI
" 192.168.2.124

i

[

1, CMT-3E87
5 192.168.2.127

a 1%-3072
T 192.168.2.136

o, CMIT-4C52
192.168.2.141

~, CMT-2C40
' 192,168.2.147

7, Default HML
" 192.168.2.151

. CMT-04B1
' 192.168.2.195

o EMT-4C51XQ
~7 192.168.1.212

History

Q

1.3 Easyweb 2.0 Login Identities

Three identity levels exist in Easyweb 2.0: [Admin], [Update], and [History]. [Admin] controls all the
settings while [Update] controls limited items. For safety, specify a password before configuration.

A password is needed for opening [History] settings, and the historical data can be backed up after

logging in with password.

The default password is 111111. After successful login, the password for each identity level can be

changed in [System Password] page.

W Easyweb

Welcome back
Sign in to continue

* ©

Admin Update History

Password
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1.4 Easyweb 2.0 Interface
Dashboard

System status and HMI status are displayed in Dashboard after login.

HMI Name: FAE Date/Time:

\‘9 cMT3072XH

EasyWeb 2.0

@ svsen Dashboard

T Network
2023/04/27 15:28:31 3:29
V2.1.53 20230322

System » Info

In this page the user can edit HMI Name / Date / Time.

\‘B MT3072XH HMI Name: E Date/Time:

EasyWeb 2.0

e Dashboard

] Network
2023/04/27 15:28:31 3:29
V2.1.53 -

System » Diagnostics

cMT-1E7C_FAE_cMT...

2.16.5

cMT-1E7C_FAE_cMT...

2.16.5

In this page the user can collect information about any errors that occur during HMI operation.
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HMI Name: Date/Time:

¢ cMT3072XH
' EasyWeb20

Diagnostics

HMI info Collector Version: 1.0.20
®  Diagnostics

T Network HMI Info Collector:

= Project

B btmiinfo-collect..enc A

Network » Ethernet

In this page the user can set the IP address of each Ethernet port.

\\P _ HMI Name: Date/Time:

Ethernet

LAN 1 (WAN)

Mac Address: 00:0c¢:26:21:1e:7¢

Configure IP: Automatic &
®
Address: 192 . 168 . 2 . 97
G
Netmask: | 255 . 255 . 252 . O
Gateway: 192 . 168 . 1 . 254
DNS: 168 . 95 . 1
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Bridge Mode
Dual Ethernet port models can be configured in Bridge Mode to allow LAN1 and LAN2 to operate in

the same network segment, providing switch-like functionality.

\\° cMT3072XH

HMI Name: cMT-1E7C FAE Date/Time: 2023/04/27 15 ® 2
EasyWeb 2.0 3

) Ethernet

e Network

Bridge Mode

® Ethemet
Enable Bridge Mode:

—

Enabling Bridge Mode triggers a confirmation window, which prompts users to verify the proper
connection of the two Ethernet ports. Failure to do so could lead to a network loop and a broadcast

storm. Once the connection is confirmed, click OK to proceed with the operation.

Attention! X

Bridge mode makes HMI behave like a two-port Ethernet
switch. And networks on both Ethernet ports are
connected in the same broadcast domain.

NOTICE: if both ports connects to the same network,
unplug one. Otherwise, this creates a network loop and
causes a broadcast storm breaking the network.

OK (5) Cancel
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Project » Project Management
In this page the user can restart / update / back up the project file.

=[=] =
@ cMT-Project Management %+
< C A F=2 | 192.168.2.121/admin/project/management % ® O H B =@ :
Dashboard / Project Project Management > admin -~

\ © cMT3152X

Easyweb 20

o Info Project Management

T Network Restart Project: Resart

Update Project:

== Project

e ProjectManagement Backup Project: Backup L

USB/SD Updaie:

Project » Email
In this page the user can edit email contacts; e.g., the groups a contact is in, and email addresses.

SlE] %
@ cMT-Email x 4+
< C A F=2 | 192.168.2121/admin/project/email %« ® OH B =@ :
Dashboard / Project / Emai 2 admin v

\ © cMT3152X

Easyweb 2.0

Q@ o SMTP Contagts Upload

] Network
*Host  stmp.gmail.com
== Project
* Username: test@gmail.com
* Password:
* Confirm Password:
Authentication: ()

Encryption: None Q9 TS SSL

Sender Information

*Name:- Local HMI Use HMI Name
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Project » Enhanced Security

In this page the user can set operable classes and password for each account.

=[] 3%
@ cMT - Enhanced Security x 4+
€« C A F=2 | 192168.2.121/admin/project/security %« ® O H B =@ :
Dashboard / Project / Enhanced Security 2 admin v
Accounts Import User Accounts
@ Please click [Save] button after editing data
- Passwor
D Hide Account a A B G D E F G H 1
1 admin 11111 N s b v o e g Vg v
Enhanced Security 2 userl 111 v
3 user2 222 4 '
4 userd 333 v v v
5 userd 444 ' e v N
6 users 555 \/ v v ~ v
7 userb 666 v b ~ ~ v v
Project » Recipe
In this page the user can update, back up, or clear recipe data on HMI.
=B &
@ cMT - Recipe x 4+
< C A F=2 | 192.168.2.121/admin/project/recipe « ® O H B =@ :
Dashboard / Project Recipe ] admin  ~
\ © cMT3152X =
Easyweb 2.0
o nio Action
Hem
] Network Update Backup Clear
2 Recipe Database Backup
mm Project
&
Backup
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Data » Data Log & Trend Display

This page displays data log and the corresponding trend. The data can be exported or backed up.
Please note that decimal places are not displayed, exported or backed up in Easyweb 2.0; however,

this can be achieved by creating a History Data Display object and a Backup object in the HMI

project and connecting the HMI using cMT Viewer.

= EES
@ cMT - Data log & Trend x 4+
<« C A F== | 192168.2.12V/admin/data/datalog % 4 OH B =@ :
Dashboard / Data / Data log & Trend 2  admin
\ © cMT3152X
Easyweb 2.0
o nfo DataLog Trend Display
Object: | logooo
2 Refresh & Option
# 3 Time Channel 1 Channel 2 Channel 3
Rl TET 235778 © 202004/0113:27:39  -0.422618 -0.574748 1.19927
235777 (© 2020/04/01 13:27:38 -0.173648 -0.777817 1.18177
235776 (& 2020/04/01 13:27:37 0.130526 -0.959746 1.09625
235775 (® 2020/04/01 13:27:36 0.382683 -1.0587 0.97082
235774 ® 2020/04/01 13:27:35 0.608761 -1.09915 0.802957
235773 ® 2020/04/01 13:27:34 0.793353 -1.07886 0.6
235772 ® 2020/04/01 13:27:33 0.939693 -0.980107 0.330765
+ Export to Spreadsheet *+ Backup database 1
= EES
@ cMT - Data log & Trend x 4+
< C A F==2 | 192.168.2121/admin/data/datalog v ® O H B =@ :
Dashboard / Data / Data log & Trend 2  admin
\ © cMT3152X
Easyweb 2.0
o nfo DataLog Trend Display
Object: | logooo
Aulo Refresh 2 Refresh & Option
45
Data Log & Trend Display 30
15
0 —
-15
30
45
1:23PM 1:24 PM 1:25 PM 1:26 PM 1:27 PM 1:28 PM 1:29 PM 1:30 PM 1:31 PM
—-0.382683 - 0914617 — 12
X_Division 8 Y. Division 7
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The display feature can work properly only when in EasyBuilder Pro, [All records in one file] is
selected in Data Sampling’s History File setting. The display feature is currently not supported for

[Customized file handling] mode.
History file
[¥] Enable

(@ All records in one file

(7 Customized file handling

File name :  |agoon

Data » Event Log

This page displays event logs, and the data can be exported or backed up.

= | =] 2
@ cMT - Eventlog x  +
& @ A F=2 | 192168.2121/admin/data/eventlog # ® 0/ g 7@ :
Dashboard / Data / Eventlbg & admin v
\ © cMT3152X
Easyweb 2.0
0 nio
Time column
g Network 2020-03-04 o 2020-04-01
Category range ( 0 - 255 )
0 - 255 -
Keywords Select Language
Add terms Language1
EventLog
# Calegory Ewvent Message Event trigger time Retumn o normal fime Occumence count
1 1 Tank Error ! © 2020/04/01 13:31:25 c] 31 =
2 1 Machine Eror It (@ 2020/04/01 13:31:25 @ 2020/04/01 13:31:31 44
3 255 Start Memory Test  (© 2020/04/01 13:31:17 (¢} 1
Flow Speed Ermor
4 1 B @ 2020/04/01 13:31:12 (@ 2020/04/01 13:31:20 17
5 1 Machine Error ! (3 2020/04/01 13:31:10 (2 2020/04/01 13:31:18 43
i} 1 Tank Error It ® 2020/04/01 13:31:06 © 2020/04/01 13:31:15 30
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Data » Operation Log

In this page the user can back up operation logs.

@ cMT - Operation Log X  +

< C A F==2 | 192168.2.121/admin/data/operationLog

® Dashboard / Data Operation Log
\‘ cMT3152X
Easyweb 20

4 Backup database
o Info
EI Network

= Project

# Operation Log

@ Features
G Account

=B =
* s 0@ BB @ :

. J admin

Features » WebView Setting

In this page the user can enable WebView and set password. Please see Chapter 2 in this user

manual for more details.

Date/Time:

3 HMI Name:

WebView Setting

Enable
Force HTTPS
Features : Use same HTTP port as Easy?ﬂeh
®  WebView Setting
Use WebView as homepage
User List
Automatic Login
Control User

View User

1010-1167 rev00
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9 Al Control Only View Only
© Disabled Control User View User

Change password &

Change password (&
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Features » CODESYS

In this page the user can activate CODESYS® and manage settings for firmware updates.

\ ® cMT3072XH HOdL e DaterTime: ) i
EasyWeb 2.0
@ ssen CODESYS
] Network
Status

Status: Not Activated

License: Activate Reslore

CODESYS

Features » FTP

In this page the user can modify FTP server related settings.

o

192168213 O @ sraus

\ ® cMT3072XH 3 HMI Name: Date/Time: 53z -  admin
\ EasyWeb 20 b

@ 5= N FTP

@ Pisthox FTP Server Enable (\

FTP client can modify USB/SD data

Port Setting reset (R

FTP port

1010-1167 rev00 11



Features » EasyAccess 2.0

In this page the user can activate EasyAccess 2.0 and configure the proxy server.

3y oMT x 4+ - =]
<« c 192.168.3.63 % 0O @ Incognit
HMI Name: Date/Time: : 2 admin -
W\ cvrsorax 3 el =
EasyWeb 2.0 3
@ e EasyAccess 2.0
@ Network
Connection
Status: 2 (Connected)
Weincloud Hardware key:
EasyAccess 2.0 Error code: 0
SessionID: 0
Password: 0
Version: 2.16.5
Domain Name:
Weincloud » Dashboard
In this page the current subscription status of Dashboard can be viewed.
+ = ]
192.168.3.63 * O @ ncognico
HMI Name: Date/Time: - 2 admi
W\ cuTaorax = e "
EasyWeb 2.0
@ sisen Dashboard
T3 Network
Region: Global
Domain: welintek_fae
Status:
Expiry Date: 1970-01-01
®  Dashboard QR Code:

@ Administration

1010-1167 rev00
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Administration » System Password

There are four different levels of password protection: System Setting, Update Project, History, and
User, and in this page the user can change the passwords. The default passwords are 111111.
[System Setting]: This is the highest level. It has an access to change all system settings, download,

upload project, back up historical data, or change passwords for other levels.

[Upload Project]: This level can download, upload project, and back up historical data. [History]:
This level controls FTP access and it can back up historical data.

[User]: This level can operate cMT X projects via cMT Viewer. Other three levels above can all do
this.

@ oMT X E=
<« C Y A F=2 | bups//132.168.2.119/admin/account/password = e 0 @ H

. :
W e

System Password

| Please select identity to edit password

| System Setting
Current password:

New password:

@ Adminisiration

® System Password

Confirm new password:

Submit Reset

System Setting
Update Project
History

User

1010-1167 rev00 13



Administration » Security

a @ SRARE
\\G cMT3072XH - HMI Name: Ce Date/Time: =0 5:33:2 €) 2 admin
EasyWeb 20 »

Security

furce .HTI'PS c
.fluto block if failed login an.etnpts reaches merlimil

Allow site embe.ddlng @
Allow CORS rsqn.xs.sts [ @]

@ Administration

Password Strength Rules Reset
®  Security

Enable password strength rules

Minimal password length

Include numbers

[Web Security]

Encrypt communication with EasyBuilder Pro, block the account when the number of failed login

attempts reaches the limit, or allow this web page to be embedded.

Force HTTPS

Auto block if failed login attempts reaches the limit

Allow site embedding

Allow CORS requests

[Password Strength Rules]

Set password strength rules that EasyWeb uses to determine whether a password is valid.

1010-1167 rev00
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Password Strength Rules Reset

Fnable pa.s.swnrd strength rules
Minil.'n:ll p.nés.sufrord Ien.gth.
In.ciude n.umbers

In.clude n.1ix‘ed cas:es .

Include special characters

[Password Expiration]

Set the password expiration policy.

Password Expiration Reset

Enable password expiration

validity period -
Enforce password update
Administration » OS Update
The OS can be updated by using EasyWeb 2.0.
192.168.3.63 fr % O @ mcognio

W eMT3072xH

Easyweb 2.0

o System os Update

@ Network

OS Update: Update:

>

@ Administration

®  0S Update

1010-1167 rev00 15



During the update process, please do not turn off the HMI.
2= Updating

© © ®

Prepare OS Update Upload OS Image Update OS

o Please wait until update has completed

Once the update is complete, the system will display the following window.

© Update Completed X

© © ©

Prepare OS Update Upload OS Image Update OS

@ 0S Update has completed!

The window below may appear for the following reasons:
1. Incompatible OS version.

2. IP address changed after OS update.
3. The OS update process took too long.

Check the device X

Unable to verify the OS update result. Please check the device and verify the OS
update result.

Common reasons:

OS is updated to an incompatible older version
IP address is changed after the OS update

OS update takes longer than expected (3 min.)

If the device is unresponsive, please contact our distributors or via our website.

1010-1167 rev00



Chapter 2 How to Use WebView

2.1 Overview

cMT X Series HMI can be monitored and controlled using an internet browser (Windows Edge,

Chrome, or Firefox). Up to 4 users can log in simultaneously.

2.2 Enabling WebView

Log in Easyweb 2.0, open WebView Setting page and toggle on [Enable]. In this page, whether a

password is required for logging in WebView can be set.
Force HTTPS: Enabling this will make WebView use HTTPS.

Use same HTTP port as EasyWeb: Enabling this will make WebView use port 80 to connect to the

VNC server when accessed via HTTP.

HMI Name: ©

\‘G cMT3072XH

Easy\Web 2.0

WebView Setting
Enable
ft.:\rce I-fTTPS:

@ Features Use san-fe H:TTP port .-35 Easy_v\.h::b
®  WebView Setting

Use WebView as homepage

Llst.-:r List

Au(or.'nalic Lugin‘

Control User

View User

2.3 LogIn WebView using an Internet Browser

Date/Time:

y O @ =smzxwm

= admin

WebView w

@]

[_®)]

9 Al Control Only View Only

Disabled Control User View User

Change password (3

Change password (@

Step1. Open internet browser and enter HMI’s WebView address (e.g.: 192.168.2.121
/app/dashboard). In WebView settings, if “Set as homepage” option is selected, then

simply enter the IP address (e.g.192.168.2.121). WebView interface opens after entering

the password.

1010-1167 rev00
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x  +
C A F=2 | 192.168.2.121/app/login?auto=stop o ¥+ % O H el = @ :

@ oMt
e

Control Mode

Step 2. The HMI screen is displayed in the browser window. Certain HMI screen resolutions may

exceed the browser window size. When this happens, to change the view area, drag the

white frame that represents browser window in the lower-right corner and move within

the gray area that represents HMI screen.

x +

S T
- % a OB BER O :

&« C A F=2 | 192.168.2.121/app/dashboard

“VNC Viewer

VNC Viewer run on HMI allows remote monitoring devices with VNC Server installed for

flexible operation.

VNC Server on

18
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Step 3. The toolbar that opens by clicking the three-line icon in the upper-left corner of the
window is shown below. From left to right, the toolbar is separated into three groups of
items.

In the first group, the HMI screen can be resized to fit in the browser window, or
displayed with HMI’s actual screen resolution.

In the second group, the position of the icon that opens the toolbar and the dragging
panel that moves the view area can be changed.

In the third group are the system settings icon and the logout icon.

@ Note

B When “Set as homepage” is selected in WebView, the WebView interface can be opened
by directly entering HMI IP address. When login password is forgotten, please enter
https://HMI _IP/admin to return to the default system settings page. This prevents the

situation where WebView functions cannot be used once password is forgotten.

2.4 When WebView Doesn’t Open

When a login attempt fails and the page below shows, try the following ways to troubleshot.

1. Check whether WebView is enabled for the HMI.

2. Check whether the browser supports WebView, and please use recommended browsers such as
Windows Edge, Chrome, or Firefox.

3. Maximum number of users may be exceeded (4 users at a time).

== 58
@ cmr x  +

&« C ® F==2 | 192.168.2121/app/dashboard ¥+ % O H [ =) @ H

CONNECTING

O —

If it takes a long time to connect.

Possible causes :

1. Webview feature is disabled on this HMI.

2. This browser does not support Webview.

3. Maxinum connections for Webview has been reached.

1010-1167 rev00 19
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Windows is a trademark or a registered trademark of Microsoft Corporation in the United States and/or other
countries. CODESYS® is a trademark of CODESYS GmbH.

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their
respective companies. This document is subject to change without prior notice.
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